西班牙个人旅游签证2015.11

本人情况:个人旅游(只在巴塞罗那待6天),在职,在北京居住,已婚。

材料准备:在西班牙签证中心网站上可以看到流程和需要的资料【北京/广州西班牙签证申请中心(北京中心的人不多呢)不需要提前预约,只有上海西班牙签证中心需要网上预约】,进入网站点击关于您的签证->短期->旅游出现下面页面:

屏幕快照 2015-12-23 下午9.38.00

点击下载相应地区的审核清单表,对于个人旅游签证需要准备的有以下几条:

  1. 一张使用英文或西班牙文大写印刷体手工填写或者打印机填写的申请表,须申请者本人签名。(未成年人则必须加上法定监护人的签字)。

屏幕快照 2015-12-23 下午10.30.46

点击申请表格按照上面的方法下载申请表格,表格填写大概如下:

屏幕快照 2015-12-24 上午9.59.05屏幕快照 2015-12-24 上午10.20.33

屏幕快照 2015-12-24 上午10.26.31屏幕快照 2015-12-24 上午10.28.58

最后两页只截了需要填写的地方。已婚的话拿上结婚证吧,可能需要看看。

2. 一张近照,彩照,白色背景,约 26-35 毫米宽,32-45 毫米长。(用的办护照时剩下的照片,剪了剪,因为办护照信息和办签证时间就差了一个月,如果照片是6个月以前的最好不要用,自己去拍一张好了)

3. 护照有效期为预计离开申根国的时间后至少 3 个月有效,有 2 张以上的空白可用页,以及所有页的复印。(只复印了护照的前两页和两张空的签证页以及最后的紧急联系人一页。另外还要额外复印一下护照的信息页,新的护照是第一页,因为递交材料之后会需要一份复印件,会把缴费单子、领护照的单子和复印件钉在一起,到时候来领护照)

4. 个人旅行医疗保险:此份保险必需承付申请人在申根国境内停留时所能发生的意外 情况所需的医疗救助和返回本国的所有费用。投保金额至少为 30000 欧元或等值的 人民币。(在中国人保上买的,问了下在网上买是包括孕妇的。。不过下载的电子保单只有网页版的,有个红色的章需要安装插件才能显示,所以还是去打印店好了,正好可以彩印)

5. 机票预定单:若申请多次入境旅游签证,首次旅行的机票预定单。注意:需为确认的往返程机票。机票应在签证签发之后出票付款!(在携程上买的往返机票,买的法航的,来回只需要6800,不过是11月14号的,不知道现在什么价位,买完之后会发一份带附件的邮件,附件就是行程预订单喽,说是预定其实是直接买的有木有,记得看一下可以托运几件行李,如果超出件数要求一件就要多交100欧哟亲,100欧哟~~)

6. 住宿证明:涵盖全部旅途的住宿证明。(在book.com上订完了发的邮件打印一下就行了)

7. 旅行计划:能够清晰展示旅行计划的文件(交通方式预订、行程单等)。

大概写一下就可以了:

屏幕快照 2015-12-24 下午12.09.48

8. 申请人偿付能力证明:最近3至6个月的银行对账单,无需存款证明。(在学校的工行用工资卡打的,告诉一下是干什么用的人家就知道怎么弄了,如果你的卡里除了工资还有突然存入的存款,那就用张纸用英文写一下这些money是怎么来的。。)

9. 户口簿原件(无需翻译):及户口簿所有页的复印件(中国公民适用)/ 非中国公 民需要提交有效的中国居留许可。(这些需要复印的两页复印在一张纸上就可以了,节约用纸爱护地球)

10. 在职人员:由任职公司盖章的公司营业执照复印件 由雇主出具的证明信(英文件,或中文附上英文翻译),需使用公司正式的信头纸并加盖公章,签字,并明确日期及以下信息: -任职公司的地址、电话及传真号码 -任职公司签字人的姓名和职务 -申请人姓名、职务、收入及工作年限 -准假证明

其实就是写一封信就可以了,从网上搜了搜,这样写的:

 

To: Visa Section, Embassy of Spain in beijing

Subject: Vacation, salary and employment certification letter for visa application

Dear officer,

we hereby certify that 你的姓名(female, born on *), whose national passport number is *,  has been employed by *(公司名称)since Feb 21,2014 and her current salary(after-tax) is *yuan(CNY *工资) per month.

Ms.* applied for a leave of 4 days from Nov 16,2015 to Nov 19,2015 (Nov 14 and Nov 15 is the weekend) for her vacation that she planned to spend in your country at her own expense. She assures to comply with Spain laws when in your country and return to her position when the vacation is over. We have approved her application and made sure that we will reserve her position and salary during her leave.

And all of Ms.*’s costs will be paid by herself. we are confident that Ms.* will return to work on time. the purpose of his trip is for travelling. She will not seek any employment or residency in Spain and will abide by the laws and regulations of Spain. We would be very grateful if you would approve her application for a visitor visa.

Please kindly afford her any appropriate assistance concerning visa affairs in case of need. If any question, please do not hesitate to contact me, the Department of CHARLS at *(领导联系方式), and telephone is*. 

Sincerely,

Manager’s name: 领导姓名

Manager’s title: Deputy director

Manager’s signature:领导签字

Company name: *

Tel: *

Fax: *

Address: *

递交资料:地址在北京市朝阳区工体北路13号院1号楼702室(海隆石油写字楼/世茂百货北面)

         进去楼里,签个字,前台刷卡进楼梯上到7楼,702拿号,把材料和护照给前台,前台按照审核清单表检查划勾,说了跟大丢一起去,看了结婚证,问有没有拿大丢的护照,我说没拿就说没拿就算了,又让我在行程单上加上一句英文大意:“大丢是商务签,我是旅游签,我们一起去。。。”,然后缴费一共500多,要现金哟。交完之后就跟我要额外的护照复印件,说是领护照的时候用,所以就取旁边的店里复印了一下,比较贵哦,所以还是提前准备的好,复印完了,把缴费单子、领护照的单子和复印件钉在一起,以后用来取护照。告诉我15个工作日内会有结果,结果两天之后就接到电话说可以去取了~~

      so easy~~吼吼~~

     c0184b30jw1ez7clsxzvsj20xc0m8jw6

ruby on rails安装(ubuntu 14.04)

安装完windows版的,有人说新手千万不要用windows版的,因为会出现莫名其妙的错误,而且解决问题的方法很少 ,恩,最近小小的使用了下,还没有什么windows特有不能解决的问题,大概是才刚刚开始。项目用的服务器是ubuntu,所以嘛,还得用linux不是,下面是ubuntu14.04麒麟下的安装方法,使用的是RVM安装,相对简单。

ubuntu 14.04 安装

1. 安装依赖:

        安装之前要使用sudo apt-get update更新一下源,否则可能会出现如libcurl4-openssl-dev
等缺少依赖的错误,在下面所有的过程中使用apt-get安装出现找不到安装包或依赖的错误,
都首先update更新一下源,这里有ubuntu 14.04 source.list源

sudo apt-get update sudo apt-get install git-core curl zlib1g-dev build-essential libssl-dev libreadline-dev libyaml-dev libsqlite3-dev sqlite3 libxml2-dev libxslt1-dev libcurl4-openssl-dev python-software-properties

安装完成后,开始使用rvm安装ruby。

 2. 使用RVM安装ruby
     其中RVM是Ruby Version Manager的缩写,即ruby版本管理器。可以自动查找并安装所需
     版本的ruby,并对ruby版本进行管理。
     安装方法如下: 这里我们使用推荐的ruby-2.1.3

a)安装依赖:

         sudo apt-get install libgdbm-dev libncurses5-dev automake libtool bison libffi-dev

b)下载rvm:

           curl -L https://get.rvm.io | bash -s stable(这句话的解释)

           Note
                                在执行该语句时,可能出现GPG signature verification failed for  
                      ‘/home/sophia/.rvm/archives/rvm-1.26.4.tgz’的错误,以为是权限的原因前面
                      加sudo,结果在ubuntu麒麟14.04一次性通过,在ubuntu14.04中还是出现上述                                                错误,然后又apt-get update了一下,再试安装成功。。。感觉跟网络思密达的                                                 有关呀。
            安装成功~
221520518223647
      c)载入RVM环境:

            source ~/.rvm/scripts/rvm                         

       d)加入shell(以后就无需每次执行上一步了)   

             echo “source ~/.rvm/scripts/rvm” >> ~/.bashrc

        e)安装ruby-2.1.3

              rvm install 2.1.3221521032447071       f)将2.1.3设为默认版本  

             rvm use 2.1.3 –default
 
       g)测试:

           ruby -v

           显示为ruby 2.1.3p242 (2014-09-19 revision 47630) [x86_64-linux],安装成功~
        h)添加设置:  告诉rubygems不要为每个本地包都安装文档

            echo “gem: –no-ri –no-rdoc” > ~/.gemrc

3.安装rails:
          首先在安装rails之前需要安装javascript runtime,如果不安装的话会出现
           rails sever时出错(请参考链接中的错误4 ExecJS::RuntimeUnavailable),
           安装方法如下:
                   sudo add-apt-repository ppa:chris-lea/node.js
                    sudo apt-get update
                    sudo apt-get install nodejs
            然后安装rails:
                   gem install rails
             Note: 
                      有可能会出现错误The program ‘gem’ can be found in the follwing packages
                           (在ubuntu麒麟上没有该错误)

最后rails -v测试成功~~~

4.使用rails:
与windows中相同rails new blog,cd到该目录下,使用rails s启动,http://localhost:3000测试 一下。

oh~myladygaga~~就这样的成功了~~妈妈再也不用担心我的学习了~~

221522429947745

The program ‘gem’ can be found in the follwing packages

错误:The program ‘gem’ can be found in the follwing packages
在使用gem时出现下面错误:
gem install rails
解决方法:
 打开终端窗口的Edit>Profile Preferences>Title and command把”Run command as a login shell”选项选上,重启终端。
gem cannot be used
okey dokey~~

rials server error

错误1:ActiveRecord::StatementInvalid
/home/diudiugirl/.rvm/gems/ruby-2.1.3/gems/activerecord-3.2.12/lib/active_record/connection_adapters/abstract_mysql_adapter.rb:243:in `query’: Mysql2::Error: Table ‘ashelf_development.accounts’ doesn’t exist: SHOW FULL FIELDS FROM `accounts` (ActiveRecord::StatementInvalid) 
…..
解决方法:
database.yml中配置了三种环境,使用不同的数据库:development、test和production,而默认的是development环境。而在上述错误中未指定production环境,让我们使用rails s -e prodution来指定,又出现了如下的错误2。
错误2:ActiveRecord::AdapterNotSpecified
/home/diudiugirl/.rvm/gems/ruby-2.1.3/gems/activerecord-3.2.12/lib/active_record/connection_adapters/abstract/connection_specification.rb:47:in `resolve_hash_connection’: database configuration does not specify adapter (ActiveRecord::AdapterNotSpecified)
解决方法:使用 RAILS_ENV=production rails s 命令来指定。
错误3:Errno::EADDRINUSE
/home/diudiugirl/.rvm/rubies/ruby-2.1.3/lib/ruby/2.1.0/socket.rb:206:in `bind’: Address already in use – bind(2) for 0.0.0.0:3000 (Errno::EADDRINUSE)
解决方法:已经有一个rails s在运行了。
错误4:ExecJS::RuntimeUnavailable
/home/diudiugirl/.rvm/gems/ruby-2.1.3/gems/execjs-2.2.2/lib/execjs/runtimes.rb:51:in `autodetect’: Could not find a JavaScript runtime. See https://g`ithub.com/sstephenson/execjs for a list of available runtimes. (ExecJS::RuntimeUnavailable)
解决方法
按照错误提示ExecJS缺失runtime,查看链接https://g`ithub.com/sstephenson/execjs 可看到,ExecJS所支持的runtime:
而通过“ExecJS lets you run JavaScript code from Ruby. It automatically picks the best runtime available to evaluate your JavaScript program, then returns the result to you as a Ruby object.”可以看到,ExecJS会自动选择一个最好的现有runtime,所以能装的gems都装一下吧。
有两种方法:一是,使用gem install therubyracer和sudo apt-get install nodejs。二是在Gemfile中加入gem ‘execjs’,并将“#gem ‘therubyracer’,  platforms: :ruby”前的注释去掉。

使用word邮件功能集合excel批量生成word文档

要给学生发实践证明了,同事小李过来求助怎样将excel表中的数据按照word文档模板批量生成学生的实践证明,遂搜了搜,找到解决办法。

首先打开word文档(word2015),模板内容大致如下:

http://images2015.cnblogs.com/blog/513123/201509/513123-20150901140155216-1125230409.png

其中XX是要填写的内容。

excel表中包括以下内容:

点击word文档的邮件选项->开始邮件合并->普通Word文档:

点击选择收件人->使用现有列表

找到需要使用的excel表格,点击打开选择相应的sheet点击确定:

可以看到word工具栏上方邮件选项变为:

将鼠标移到需要插入的数据处,比如XX大学,点击插入合并域,选择学校具体名称点击插入:

此时word模板变为:

将多余的字删掉,其他需要插入的内容同上操作,最后word文档变为:

稍作调整后就可以通过完成并合并来批量生成了:

点击完成并合并选项,选择编辑单个文档:

选择全部点击确定,即可批量生成在一个word中~~现在就可以轻松打印了~~

http://images2015.cnblogs.com/blog/513123/201509/513123-20150901142215216-442719926.png

哈,妈妈再也不用担心我被excel和word搞昏头了,心情好靓~哦~

655dd5f3gw1ewaybu2qytg20a505pu0x

 

ruby on rails 安装(win8 64位)

最近工作需要学习一门新语言:ruby。久闻大名,知道她的存在是因为网上流传的一篇文章 《怎样在两个月内教会妹妹与女友编程》
今日终于要用到了,有些小激动呢~~又学了门新语言来~~
电脑系统是win8,在win8下的VMware里装了个Ubuntu 14.04 麒麟,昨天下午先搞明白了win安装。
Win8 64位安装
1. 安装ruby

        在win下安装 rubyinstaller会根据你的电脑系统下载的,比如说本文是2014.11.25下载的,版本为 rubyinstaller-2.1.5-x64.exe。当然由于是日本人开发的所以只有日语和英语的版本,选择后accept协议,进入以下界面:

                Note:
                     1.  一定要把中间的Add Ruby executables to your PATH给选上,将自动将ruby路径
                         添加到环境变量中。然后安装,ok~ 
                      2.  安装路径要注意,第一次安装的时候安到E:\Program Files\bla bla…这样的目录
                         下,在后面安装完rails的时候会出现类似’ ”E:Program不是内部或外部命令这样的错
                         误 ,后来发现可能是目录中文件夹有空格识别不了。最后直接安装在根目录下就好
                         了~         

最后输入在命令行下输入ruby –v测试一下:

             clipboard1

      hoho~~安装成功~~so easy~~


2. 安装rubygems     在win下需下载zip版 Rubygems,解压后 执行目录下的setup.rb,例如2014-11-25下载的版本是rubygems-2.4.4.zip解压后:clipboard2

     在命令行执行 ruby setup.rb命令:

     安装完成后用 gem -v测试一下:
      oh~yeah~
           c0184b30jw1elugbupmcog209w05ke83
 
3.  安装rails
 
     远程安装的话,如果网络不够好,是需要很长时间的,所以我们就手动来好了~ruby所需gem在rubygems.org网站下搜索下载即可(这里所有软件都是使用的现有最新版本)。
    首先需要下载rails所需依赖, 其实在这里就可以看到安装rails所需要的依赖:
clipboard5
   
     但是通过安装时间推算出其中有几个依赖在安装过程中包含了其他依赖,比如安装了activerecord时就已经安装了view和model:
     所以最后依赖的安装还是按照之前版本的rails安装,要按下面顺序来~~
          a) 下载以下 activesupportactiverecord  actionpack actionmailer rake rails
             (右下角有个download,自动下载当前最新稳定版本,2011-11-25是
              activesupport-4.1.8.gem)
              下载后把所有gem放到同一个文件夹下(例如c:\ror)
          b)使用gem install命令按顺序安装:     
                  gem install  activesupport-4.1.8.gem
                  gem install  activerecord-4.1.8.gem
                  gem install  actionpack-4.1.8.gem
                  gem install  actionmailer-4.1.8.gem
                  gem install  rake-10.3.2.gem(会提示覆盖ruby的rake,上述ruby版本的rake版本比这个低)
                  gem install  rails-4.1.8.gem

             c)测试一下: rails -v

               clipboard7            

                Note:

                             发现这句话没有:DL is deprecated, please use Fiddle 。这个是一个Warning信
                            息,不用太在意,但如果实在嫌弃它的话可以根据下面这个文章将其去掉,方法:
                            去掉DL is deprecated, please use Fiddle错误信息。                         
4.  创建并运行web应用
           a) 创建使用rails new ApplicationName来创建新的web应用,例如进入应用保存目录输入命
              令 rails new Blog 会显示create一些文件, 并会运行 bundle install 命令检查Gemfile中
              的依赖是否可行。
              那么在保存目录就会出现名为Blog文件夹,并包含了自动生成的一些文件:
          Note:
                       这一步因为执行了bundle有可能出现这样的问题:Gem::InstallerError:The ‘json’
                       native gem requires installed build tools……      
                      解决办法参照:Gem::InstallerError:The ‘json’ native gem requires installed
           b) 启动服务器:
             下面让我们来启动一下ruby on rails自带的服务器webrick,在这个版本中,启动命令
             为:rails s(or server) (在应用目录下执行,例如….\Blog\):
clipboard10
            然后在浏览器输入http://localhost:3000测试一下吧~~
clipboard11
           Bingo~~成功了~~
            Note:
                   如果出现了:C:/Ruby21-x64/lib/ruby/gems/2.1.0/gems/tzinfo-1.2.2/lib/tzinfo
                  /data_source.rb:182:in `rescue in create_default_data_source’: No source of
                  timezone data could be found. (TZInfo::DataSourceNotFound)的错误,请参
                  照:data_source.rb:182: TZInfo::DataSourceNotFound
       c) 运行应用:
              rails是一个由ruby语言写的框架,可以参照 rails指南来了解。

              首先在新生成的应用中使用generate命令 rails g(generate) controller welcome index
              建一个名为welcome的控制器,如下:

 

clipboard12
           可以看到在app/controllers和app/views下生成相应的控制器和视图。编辑视图
           index.html.erb,随便写点东西进去如…     

           clipboard13

           然后重头戏来了~~设置应用的入口即首页:      
           打开Blog/config/ routes.rb文件:

        clipboard14

           其中get ‘welcome/index’是在执行上述 rails generate controller welcome index命令时生
           成,该语句告诉rails在访问http://localhost:3000/welcome/index时执行welcome控制器
           中的index动作。在上图可以看到有一行root开头的root ‘welcome#index’去掉前面的注
           释,该语句告诉rails访问根路径时交给控制器welcome中的index动作处理,此时输入
           http://localhost:3000时便会显示index中的内容:

          妈妈再也不用担心的ruby on rails环境了~~好开心~

           c0184b30jw1emgfi0bo7yj20zk0k0n04